Acura TSX Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
519 Posts
I believe that those are the Iridium plugs. If so, they don't look bad. It's hard to say but if you think that you're performance is down then feel free to replace. I usually change mine at 100k and they always look good and I don't feel much of an improvement but I generally am always ahead with my maintenance.

If you don't want to change them you could clean them up (re-gap, wire brush tip and coil/plug wire end, make sure the coil end is tight) and see if there is an improvement.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
I believe that those are the Iridium plugs. If so, they don't look bad. It's hard to say but if you think that you're performance is down then feel free to replace. I usually change mine at 100k and they always look good and I don't feel much of an improvement but I generally am always ahead with my maintenance.

If you don't want to change them you could clean them up (re-gap, wire brush tip and coil/plug wire end, make sure the coil end is tight) and see if there is an improvement.
not that i know of if thats and old iridium plugs,,but i just decided to change it out, no change on profmance,, also i willchange transmission oil in the next few months
 

·
Registered
Joined
·
10 Posts
Cant tell if thats damage to the last plug, carbon build up or maybe something else like antiseize, but those look fairly normal for K24/K20 based vehicles. I also recommend replacing them ever 100k or as necessary.
 
1 - 4 of 4 Posts
Top