Acura TSX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an '09 TSX with the 4-cyl and automatic. The car feels very responsive coming from a stop, but when trying for serious acceleration, like getting onto the highway, it surges and hesitates. It feels like it needs the fuel filter replaced, but there is none on this car. I've run fuel injector cleaner, and that didn't help. I then tried Seafoam in the tank and that didn't help it. Suggestions?

Thanks,
Darrin
 

·
Registered
Joined
·
1 Posts
I have an '09 TSX with the 4-cyl and automatic. The car feels very responsive coming from a stop, but when trying for serious acceleration, like getting onto the highway, it surges and hesitates. It feels like it needs the fuel filter replaced, but there is none on this car. I've run fuel injector cleaner, and that didn't help. I then tried Seafoam in the tank and that didn't help it. Suggestions?

Thanks,
Darrin
I have an 09’ TSX with 165k miles at the moment and I had an issue with the engine hesitating to get to redline, which eventually in time started going into limp mode if I even tried to get to redline. Normal driving is fine though. I can suspect that your hesitation can be a clogged cat. More than likely the pre-cat that maybe clogged which what I have to deal with. Check also for permanent fault codes on the OBDII if there’s anything like P0420 that can lead to a clogged cat or even something small as oxygen sensors.
 

·
Registered
Joined
·
3 Posts
I recently had to replace my accelerator pedal position sensor. My car ultimately went into limp mode and threw a bunch of codes but the symptoms leading up to that were slight hesitations when accelerating. How many miles are on your car? I think its fairly common for the accelerator sensor to go at around 160k
 

·
Registered
Joined
·
3 Posts
Also there is a fuel strainer at the bottom of the fuel pump assembly, maybe that could be clogged up?
 
1 - 4 of 4 Posts
Top