Acura TSX Forum banner

341 - 360 of 401 Posts

·
Premium Member
Joined
·
167 Posts
That sucks. I'm not an electronics expert, but based on what you said, it sounds like a corroded or bad contact on the harness plug or radio. Test continuity, clean with contact cleaner (do this with the PCB too) and maybe put a dab of dielectric grease on the plug contacts before trying again.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
375 Posts
That sucks. I'm not an electronics expert, but based on what you said, it sounds like a corroded or bad contact on the harness plug or radio. Test continuity, clean with contact cleaner (do this with the PCB too) and maybe put a dab of dielectric grease on the plug contacts before trying again.

Sent from AutoGuide.com Free App
Didn't think about that. I'll try it and see what happens. Thanks
 

·
Registered
Joined
·
375 Posts
That sucks. I'm not an electronics expert, but based on what you said, it sounds like a corroded or bad contact on the harness plug or radio. Test continuity, clean with contact cleaner (do this with the PCB too) and maybe put a dab of dielectric grease on the plug contacts before trying again.

Sent from AutoGuide.com Free App
So i tried it and no luck. I am going to try and change the harness (not complete harness but cut and attach pigtail)
 

·
Registered
Joined
·
62 Posts
Is there a "real" resolution to this? I swear my 04 has all the 'typical' problems. Maybe one day I'll get around to fixing all of them. But if I buy that board will it fix it? At 127k miles, going to the dealer won't help me.
 

·
Registered
Joined
·
62 Posts
Acura wants $400 to replace the pcb and supposedly they need the car first to order it?? Still... Im going to do it myself. The board isn't but $70 not including the core charge, and $30 if I want the markers and wrist strap. The acura stealership won't be seeing my business anytime ever.
 

·
Registered
Joined
·
62 Posts
So today I was messing around trying to see if I could fix it by unplugging the battery and replugging in my usaspec ipod adapter - I also rerouted its wiring so it wasnt all crammed in the console.

Now my overhead passenger light is out in addition to the radio lights and a/c lights. The radio display, clock and a/c lcd work as well as my passenger seat heater backlight. Everything else is dark still.

Sigh. Im going to order this PCB as soon as possible but it might be two weeks. Is it possible that the LCD for the radio and a/c controls will go out too??
 

·
Registered
Joined
·
62 Posts
Just to add, my 04 dome lights are out, my CD/Radio buttons do not work, and when adjusting ac on the screen display, the display touch buttons do not highlight blue as they used to, seat heat light out, clock display is out so I can't see time, temperature for climate control, and while using the navi map, the caption "climate control off" pops in and out every very few seconds. Is the PCB related to all of these issues?
 

·
Premium Member
Joined
·
167 Posts
Now my overhead passenger light is out in addition to the radio lights and a/c lights. The radio display, clock and a/c lcd work as well as my passenger seat heater backlight. Everything else is dark still.
Just to add, my 04 dome lights are out, my CD/Radio buttons do not work, and when adjusting ac on the screen display, the display touch buttons do not highlight blue as they used to, seat heat light out, clock display is out so I can't see time, temperature for climate control, and while using the navi map, the caption "climate control off" pops in and out every very few seconds. Is the PCB related to all of these issues?
I know this is very frustrating situation. Electrical issues take time and patience to troubleshoot, which is never a good combination for people like me :)

In both of these situations where I pulled out the quotes, it does not sound PCB related. The reason is that the dome light will function just fine with the radio completely disconnected.

When you have some time and good lighting, pull out a multi-meter and check the FSM for troubleshooting procedures. If I had to guess, it sounds like you're both dealing with a damaged wire harness or wire plug/connector issues.
 

·
Registered
Joined
·
62 Posts
Well I plan to replace the bulb in my dome light to see if that is causing it. I also have my moonroof and vsa switches not light up either and that again is probably the bulbs.
 

·
Registered
Joined
·
62 Posts
Umm so which part do I order?

3917A-SEC-A01CP
3917A-SEC-A01RM

The TSB calls for: 3917A-SEC-A01RM as the part and then under warranty claim information it says "Use the RM part number (from the repair order) without RM. Example: 3917A-SEC-A01"

There is no part 3917A-SEC-A01.. only RM or CP. I dont have navigation and I need this board to fix radio/hvac. I was going to order this tonight but I have no idea which one is the one I should order since the TSB references.

Here is a pic of the TSB I am referring to:



acurapartsforless has both the RM and CP parts and acuraoemparts only has the CP part. Acura wants $400 to do this, since my car is out of warranty and they wont goodwill warranty the work I am alone and forced to do it myself.

Seems like others used the CP part? But I just want to make sure...
 

·
Registered
Joined
·
5 Posts
So I am starting to experience the radio, clock, and HVAC back light flicker on me. I know the PCB has been replaced a few years ago. Seems like the back light flickers more when I start the drive vs longer into the run. Everything else seems fine, not sure if it is the PCD, or battery (management) issue.
 

·
Registered
Joined
·
5 Posts
I guess no one has seen it flicker more at the beginning of the drive and no flicker or less later on the drive?
 

·
Premium Member
Joined
·
167 Posts
If I had to guess, it sounds like faulty capacitors on the PCB and you're experiencing symptoms when they're cold vs warm. Since it was probably replaced, pull it for inspection. If it looks ok, clean the contacts on the board with electronics/contact cleaner and firmly reinsert. If you're still having trouble, follow the troubleshooting in the FSM.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
6 Posts
I just did the replacement. Lights on console which were the clock, ac, and radio were flickering and cutting out. Delray sent the board with core charge which totaled $220 with $110 core refund. The old board had discoloration where the replacement PCB had a heat sink added to that spot. The replacement took me 1.5 hours since I have never have gone into the console. The tools I used were plastic pry bars for removing trim and three different sizes of Philips drivers.There was a problem with the provided radio code and I posted a new thread on how to resolve code issues.
 
341 - 360 of 401 Posts
Top