Acura TSX Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
hi there!

so my stock suspension finally went out and i use my TSX as a daily driver. decided to go with tien basics for a simple and somewhat comfortable drop. when i did get the tien's installed... i replaced the OEM upper mounts so everything drops and wears evenly. anywho... 1000 miles later... all my upper mounts were gone to shit. after checking out the tien basics posts, everyone seems to have gone with the stock OEM upper mounts.

i was wondering if anyone knows of any solid aftermarket upper mounts sold or any recommendations to avoid constant upper mounts replacement.

please let me know! :toocool: oh and thanks in advance.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
I used the oem upper mounts that came with the car. The car is on over 100k and no problems.
how low is your car? i'm thinking it might have a correlation to how slammed it is.

i called tien to see if they make any solid upper mounts and they have nothing... wtf.
 

·
四世
Joined
·
1,767 Posts
Sorry, don't mean to be picky, but the company name is Tein not Tien. :)

Use OEM upper mounts. I bought a brand new set from Marcus (Heeltoeauto) and ran them on my Basics for almost 60k and had no problems with them. The reason I bought them new was because I didn't want to mess with a spring compressor...
 

·
Registered
Joined
·
36 Posts
Discussion Starter #5
Sorry, don't mean to be picky, but the company name is Tein not Tien. :)

Use OEM upper mounts. I bought a brand new set from Marcus (Heeltoeauto) and ran them on my Basics for almost 60k and had no problems with them. The reason I bought them new was because I didn't want to mess with a spring compressor...
oops. my bads. didn't mean to spell Tein wrong! :shock:

anywho... hopefully a new set will make things normal and stable.
 

·
wine em, dine em, cl9 em
Joined
·
940 Posts
i have been max low on basics with oem hats for the last 3-4 years. zero issues.
 
1 - 8 of 8 Posts
Top