Acura TSX Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Installed an Injen CAI. As soon as it got colder the check engine light came on. Related to the CAI?

Second issue, when I start the car, the VSA light will turn on and stay on until ive driven in the car for a while and then turned it off and then back on. Any ideas?
 

·
Save the Manuals!
Joined
·
63 Posts
Check your oil ASAP. Get the code read ASAP. You don't want to dilly-dally and wait, not even for a day. Don't ask me how I know... :soapbox:
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Went to autozone. I got the code read for free. The code is P0341.
The printout says: Cam sensor condition.
The camshaft position sensor signal is monitored for errors.
Probable cause: Cam sensor defective
Check connector and wiring to sensor
Engine mechanical condition timing belt/chain out of time
Cylinder misfire - check ignition system for faults - plugs, wires, coils.

any help would be appreciated. This is all new to me.
 

·
Save the Manuals!
Joined
·
63 Posts
Ouch...

Well I guess it's contagious. You're not going to want to hear this. Good chance your timing chain has stretched. I strongly suggest not driving... not even starting the car, until you have it diagnosed and fixed. There MIGHT be time to save your engine if the car is still running ok.

Good news- it has nothing to do with your intake. Bad news- it's going to be either expensive or very expensive.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
I took the car to the dealership a little while ago and had them do an oil change, flush and full, and diagnostic with the Acura. Got a report back saying that the timing chain was fine. I specifically asked about it and remember her responding because I asked about the timing "belt" and she corrected me saying "chain" and assured me it was fine. Since then Ive driven the car and had no problems.
Im not saying thats not what it is though. My money is on the spark plugs. I think I noticed some misfiring but Im not sure. However, I will take your advice on not driving it until I figure it out. Its a good thing I have two vehicles:)

Do I need to take it to the dealership to get it diagnosed?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #9
Well today I decided to change the spark plugs. Did this without a problem. While I had the hood up I noticed my coolant was below min and my oil was also low so I added to both of them. Started the car and the check engine light and vsa ! light were still on.
 

·
Save the Manuals!
Joined
·
63 Posts
Ugh, get that timing chain and tensioner checked. If the dealer won't help you, find a good independent mechanic. I just dropped 3500 on a new engine. You don't want to follow in my footsteps. :(
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
Ive got an appointment with the dealership at 830 tomorrow morning. Im kind of afraid to drive it over there.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
Its the timing chain. Says its loose but isnt causing any problems at the moment. They quoted me 1300 for the fix.
 

·
Save the Manuals!
Joined
·
63 Posts
Well you can shop around for a better price, but don't listen to them about driving the car. Leave that mutha parked. The day my engine grenaded, it drove fine on the way to work (just the lights), sat all day, then was undriveable when I got off work.
 

·
Save the Manuals!
Joined
·
63 Posts
105,000
 
1 - 16 of 16 Posts
Top