Acura TSX Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
I backed my car out of the driveway to pick-up a friend for work. When I got on the street I noticed the VSA light and exclamation light were staying on. It did this all the way to work in fact. I pushed the VSA button to see if it would make it go off but nothing happened.

When my job was over, me and my friend got back in the car 10 hr later. My friend noticed the VSA light was off. I pushed my VSA button and I was able to turn it on and off now. The VSA light stayed off all the way home.

I have never had such a problem with my car like this yet. Its a Dec 04 TSX at 37,000 ish miles. (The owner before had alot of highway miles between Portland OR and somewhere in California.) My car is still under warrenty. I am not sure what to make of this...

I went back 6 pages in the TSX problems to hear others issues with VSA but I could only find one situation that was nothing like mine.

Any ideas?
 

·
Registered
Joined
·
161 Posts
Same thing happened to me one day. There was snow on the ground so my VSA had been active that day. I was driving down my street and I pulled over for snow plow to pass. When I started moving again I noticed my light was staying on and I pushed the button also and it stayed lit. I pulled over again turned the car off waited a min. and restarted it and it was off like yours and perfectly fine. I have no clue but it's never done that til now. I have an 05 35,000 miles and six speed also. Don't know but it's never happened again.
 

·
, Administrator Emeritus
Joined
·
4,123 Posts
It happens once in awhile. As long as the warning light does not remain to stay activated on your dash after restarting your car, you shouldn't need a dealership check-up.

That's the problem of having too many electronics. :banghead:
 
A

·
Guest
Joined
·
0 Posts
I was driving my girlfriends TSX when the VSA light, exclamation point, and the engine malfunction light popped on. It also would not shift out of 3rd or so gear. We took it to the dealership, they could not duplicate the problem (the lights when out after we the car off and then back on.) That afternoon, the car would not shift out of 4th gear and took it in again. They are not replacing the whole transmission...Not sure if they were related, but none the less a weird problem.
 

·
Registered
Joined
·
708 Posts
I am 80% sure you have some cable or socket lossen or not connected properly. Try to go back to your dealer and tell them what you think and let them double check for you. Good luck and Drive safe.
 

·
Registered
Joined
·
8 Posts
i think yo ushould get it looked at. My audi had similar problems with ESP, and i just ignored it, but it got more frequent after a year
 

·
Un-Civil Engineer
Joined
·
2,205 Posts
I just had this same issue fixed under warranty a month ago. The VSA light would just periodically come on and stay lit. The dealership replaced the brake switch.

Just make sure they adjust it correctly. While I was driving home from the dealership, I noticed that my cruise control would not work. It turns out that they did not have the brake switch set properly, so it was constantly active and did not allow the CC to engage.
 

·
Registered
Joined
·
1 Posts
I have read on here where a couple people have had the "Brake Switch" replaced to fix a VSA issue. I am having the same problem with my VSA, can anyone tell me where the "Brake Switch" is that was replaced?

Thanks
 

·
Registered
Joined
·
22 Posts
i am too waiting for an answer ... unfortunately my car is outta warranty and was wondering if replacing this "brake switch" was easy enough i could do it myself.
 

·
Registered
Joined
·
183 Posts
noodle710 said:
i am too waiting for an answer ... unfortunately my car is outta warranty and was wondering if replacing this "brake switch" was easy enough i could do it myself.

yes the brake light is really easy to fix. the brake light switch is located right on top of the brake pedal. is a switch that turns your brake lights on and that system is connected with the abs system and the traction.. my 00 jetta is light that and i have the same problem with my tsx
 
1 - 14 of 14 Posts
Top