Acura TSX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My dealer is suggesting a replacement of my water pump as a routine maintenance item at 110K on my '04 TSX. It's not in any schedule I've seen and I not about to do this. Anybody have any problems with their water pump that would make me reconsider?
 

·
Registered
Joined
·
2,790 Posts
I know on my old hondas..when I changed the timing belt, they'd change the water pump at the same time..I'm not sure about the tsx though. Are you at 110k miles or km?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
110k miles. If I had a timing belt I'd probably do that. I might have them change the drive belt but again the schedules just call for an inspection. I've not heard of any water pump problems on the TSX. Maybe it's because the dealers change them at 110K. Then again my dealer keeps referencing a '03 TL schedule when he tries to suggest maintenance to me. If he can't even figure out what car I have .........
 

·
Registered
Joined
·
895 Posts
ijust changed mine at 115k a few months ago.. it had a small leak and temp would rise a slight bit while standing so i just changed it while it had life left. I would say it's not a bad idea to get it outta the way. cost me under 300 to do the job.. mine is an 04 as well.
 

·
Registered
Joined
·
10 Posts
I'm about to do this, my bearing is starting to go...and I thought it was my motor :x I let the oil get to low :(
How do you know if bearing is going? any sign? reason i ask, is mine is a low mileage but at 9 years old, wondering if i need to change it. also there are some high pitch noise at low engine speed sometimes since... 5 years ago!!, i wonder if this is the air bubble trap inside, or water pump?
 

·
Registered
Joined
·
142 Posts
sorry to bring back an old thread but I think my bearing is also starting to go out on my water pump. My car has 164,XXX miles on it and I believe the previous owner never changed it.
 

·
Registered
Joined
·
430 Posts
I replaced my pump and my auto tensioner at about 170 k miles. My tensioner was going out of spec and when I spun the pulleys on the pump it was rather rough. I detailed the process with pics on another Acura forum. I don't know the rules about posting links to other forums so if you're interested, send me a PM for the link.

The main advice is to get a genuine OEM pump. The aftermarket one that was guaranteed an exact fit on Advance Auto's website did not fit.
 

·
Registered
Joined
·
5 Posts
Hi new here. Just saw this post...what's the link...please pm me

I replaced my pump and my auto tensioner at about 170 k miles. My tensioner was going out of spec and when I spun the pulleys on the pump it was rather rough. I detailed the process with pics on another Acura forum. I don't know the rules about posting links to other forums so if you're interested, send me a PM for the link.

The main advice is to get a genuine OEM pump. The aftermarket one that was guaranteed an exact fit on Advance Auto's website did not fit.
 
1 - 10 of 10 Posts
Top