Acura TSX Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Just had rotors and pads replaced ('12 TSX wagon, 58K miles) and now have a scraping noise coming from passenger front wheel when driving. occurs all of the time, driving straight, turning either direction, coasting in neutral. been 3 weeks since the initial work, thought it might wear down but it did not. had it back to the shop and they said some rust must have infiltrated when the brakes were replaced. they infused some grease and it reduced the noise for a short period but it returned. checked the heat shield and tightness of the wheel for possible bad bearing both were okay. anyone have a similar experience?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the advice and the documentation link. Took the wheel off hoping that was going to be the issue but they appear to be installed correctly. Think I'm going to bite the bullet and bring it to Acura service rather than my local mechanic who did the brake job.
 

·
Registered
Joined
·
334 Posts
Any way you can post a recording of the sound?

I had scraping sound with my new brakes a few months back and it was because I reused the old retainers and even cleaned and shined them up real nice. Ended up swapping them out with brand new ones and haven't heard a peep from them since. It's possible that your mechanic reused the old ones. Pretty cheap to find on Amazon at about $13 shipped if you have Prime.

While you have the caliper open, might as well check if your caliper guide pins are adequately lubricated.
 
1 - 5 of 5 Posts
Top