Acura TSX Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have an 07 tsx.

I am currently having some problems with my driver side wiper blade. It fails to stay flush against the windshield after i start using it or use the quick squirt function.

I know that the wiper blades are the correct size "26 inch on driver side & 16 inch on passenger side.

Could it possibly be a bent wiper arm.

Please help.
 

·
Premium Member
Joined
·
857 Posts
Use OEM wipers and replace them with the silicon when needed. It's the cheapest option and the best ones for our car. I found out the hard way by going from the RainX to Teflon to OEM. After switching back to OEM, I found there was barely any noise when wiping and a perfect wipe almost every time.

I really hate those one piece wipers. I feel like they BS when they say it's always a perfect wipe because there's no reinforcement or w/e. Local dealer was give or take $50 for both sides, then if I need to replace the silicon, it's like $5.
 

·
Registered
Joined
·
342 Posts
Use OEM wipers and replace them with the silicon when needed. It's the cheapest option and the best ones for our car. I found out the hard way by going from the RainX to Teflon to OEM. After switching back to OEM, I found there was barely any noise when wiping and a perfect wipe almost every time.

I really hate those one piece wipers. I feel like they BS when they say it's always a perfect wipe because there's no reinforcement or w/e. Local dealer was give or take $50 for both sides, then if I need to replace the silicon, it's like $5.
When you were referring to silicon, are you talking about aftermarket replacement inserts? The original inserts should be rubber

Plus, 06+ have different oem blades as 04-05. 06+ have the single beam low profile.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top